Johannes

Budapest, Hungary

Age: 25

Feb
10
awarded Popular Question
Jul
9
awarded Student
Jul
9
awarded Scholar
Jul
9
accepted Approximation for metric TSP: Worst case using nearest neighbor heuristic?
Jul
9
awarded Informed
Jul
9
asked Approximation for metric TSP: Worst case using nearest neighbor heuristic?
Jun
10
awarded Caucus
May
30
awarded Student
May
30
asked How to display a star rating widget in an ExtJS list itemTpl?
May
24
comment OSGi: servicereference.getBundle().getVersion() - No such method error
Thanks so much! I never realized I was deploying my bundles to a platform running an old version of OSGi and wouldn't have ever found out about it. Now updating all the bundles...
May
24
accepted OSGi: servicereference.getBundle().getVersion() - No such method error
May
24
comment OSGi: servicereference.getBundle().getVersion() - No such method error
I'm using the Equinox servlet bridge ( eclipse.org/equinox/server/http_in_container.php ) for an Equinox 3.7.2 OSGi platform within a servlet running on a Tomcat 7 server.
May
24
awarded Commentator
May
24
comment OSGi: servicereference.getBundle().getVersion() - No such method error
I edited my post and it now shows the return value of currentBundle.getClass() (I hope that's what you meant, is it?) as well as that way too long stack trace.
May
24
revised OSGi: servicereference.getBundle().getVersion() - No such method error
Added the stacktrace, sorry!
May
24
asked OSGi: servicereference.getBundle().getVersion() - No such method error
May
9
awarded Scholar
May
9
accepted Setting OSGi import version restrictions dynamically?
May
9
comment Setting OSGi import version restrictions dynamically?
Thanks for the clarification on the import and for the advice. With every new version of Bundle B there should be new implementations of the service tasks so I will try providing them for Bundle A using OSGi services. Thanks!
May
8
asked Setting OSGi import version restrictions dynamically?
1 2 3